Back to overview
Maintenance

Server infrastructure upgrade maintenance

May 21, 2026 at 11:49am UTC  –  May 21, 2026 at 1:49pm UTC
Affected services
Billing Portal
Noida
Mumbai Game Server
Mumbai Game Server #2

Resolved
May 21, 2026 at 1:49pm UTC

Maintenance ended

Created
May 21, 2026 at 11:49am UTC

We are upgrading the servers related to game hosting for better performance.