Minecraft Game Servers Under Maintenance
Resolved
May 6, 2026 at 2:13am UTC
Maintenance ended
Affected services
Created
May 5, 2026 at 5:13pm UTC
Our upstream network provider has informed us that their networking team will be carrying out overnight maintenance to implement firewall and network security improvements.
During this period some services may experience temporary downtime, higher latency, or brief connection interruptions.
We sincerely apologize for any inconvenience and appreciate your patience while these improvements are being completed.
Estimated Duration: Overnight Affected Services: Minecraft servers and related services
Affected services